# TABLE OF CONTENTS

ABOUT THE INTERACTIVE SCENARIO BUILDER (ISB) ................................................................. 3
PLANNING A SCENARIO ........................................................................................................... 4
INSTALLING THE ISB ............................................................................................................. 5
SCENARIO SCREENS .............................................................................................................. 6
GENERAL NAVIGATION ......................................................................................................... 7
PROCESSING PHOTOS FOR THE ISB USING PHOTOSHOP ................................................. 8
IMPORTING PHOTOS ............................................................................................................. 9
USING VIDEO INSTEAD OF STILL PHOTOS ......................................................................... 10
THE TITLE SCREEN ............................................................................................................. 11
THE TEXT SCREEN ............................................................................................................. 12
THE INTERVIEW SCREEN ................................................................................................... 13
  ADDING INTERVIEW QUESTIONS (OR ITEMS) ................................................................. 14
  ADVANCED INTERVIEW FEATURES: PREREQUISITES ...................................................... 15
  ADVANCED INTERVIEW FEATURES: GUIDELINES ............................................................ 16
  ADVANCED INTERVIEW FEATURES: LEVELS OF IRRITATION .......................................... 17
  EDITING INTERVIEW QUESTIONS (OR ITEMS) ................................................................. 18
THE Q&A SCREEN ............................................................................................................. 19
THE COURSE OF ACTION SCREEN ...................................................................................... 20
THE FEEDBACK SCREEN .................................................................................................... 22
THE MULTIPLE CHOICE QUESTION SCREEN .................................................................... 23
SAVING AND PUBLISHING YOUR SCENARIO ................................................................. 24
VIEWING A COMPLETED SCENARIO ................................................................................. 25
CONTACT INFORMATION ................................................................................................. 26
About the Interactive Scenario Builder (ISB)

The Interactive Scenario Builder (ISB) allows you to create online scenarios without any knowledge of programming. These scenarios simulate an interaction with a virtual person (VP). Learners select questions from a list to ask the VP. The VP responds differently to each question via a text balloon (or Flash video clip). You can set up a scenario using any number of screens in any order. Screen options include Text, Interview, Q&A, Feedback, Course of Action, and Multiple Choice question.

As a scenario author you write all of the content, such as:

- The scenario: What is the person’s story? Where is he or she at in their process?
- The goal of the interaction: What are the learning objectives?
- The questions learners can ask the virtual person: There should be a wide range of questions, some appropriate and some inappropriate.
- The virtual person’s response to each question: Just like in real life, you may want learners to encounter some unexpected answers to questions.
- Course of action options: Do you want your learners to select a course of action for the virtual person? If so, there should be a wide range—some good, some bad.

Once you have planned your scenario, simply open the input tool, select the screens you want, and enter the information. When you are done, you select File → Create Course and the ISB automatically compiles your information into a finished, web-ready scenario. All of the necessary files are assembled in a single directory on your computer that your network administrator can upload to the web.
Creating the online simulation using the input tool is the easy part.

Coming up with effective scenarios and writing a "superlist" of questions and course of action options involves some planning.

Before you begin writing a scenario, you should take a look at a finished one: www.csh.umn.edu/isb

Here are some things to consider before you start writing your scenario:

- What is your instructional goal with this simulation? For example, do you want learners to solicit specific information from the virtual person? Do you want them to practice dealing with a difficult situation before they encounter it in real life?

- Do you have a guideline, model, or framework for the interaction that you want learners to apply?

- What details do you want to give learners about the VP and the situation at the very beginning?

- At what point in time is this interaction taking place?

- What are the important questions that the learner should ask in this situation? How would this patient respond to these questions? What nonverbal cues would they give?

- What are some inappropriate questions or statements? How would the VP respond?

- Should the learner ask certain questions before others (is there an order they should follow)?

- What aspects of the interaction would you like the learner to reflect on? For example, would you like them to reflect on how they feel after dealing with a difficult patient?

- Are there appropriate course of action options in this situation? How would this particular person respond to them? (People might reject good course of action options!)

- Are there inappropriate course of action options in this situation?
INSTALLING THE ISB

To install the ISB:

• Double click the Interactive Scenario Builder Install icon.

• It will install the program in your Program Files folder. It automatically puts the necessary files into the Program Files folder on your computer (see the screen captures on the right). If you prefer, you can save the program in another folder (but then the shortcut will not appear on your desktop).

• It also creates a shortcut on your desktop.

To launch the program:

• Double-click the shortcut icon. (Or click the application file in the folder where you installed the ISB.)
**SCENARIO SCREENS**

You can select any of these screens for your scenario, in any order.

<table>
<thead>
<tr>
<th>Screen Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text</strong></td>
<td>The screen has space for text and a graphic. You can use this screen for a variety of purposes, for example, to introduce the scenario and the virtual person, a summary screen, or to provide additional information to the learner.</td>
</tr>
<tr>
<td><strong>Interview</strong></td>
<td>The <strong>Interview</strong> Screen has a &quot;Superlist&quot; of questions that the learner can ask the VP. The VP responds to each question.</td>
</tr>
<tr>
<td><strong>Q&amp;A</strong></td>
<td>The <strong>Q&amp;A</strong> Screen poses a general question to the learner and a discussion. For example, you could ask the learner “How do you think you did in the interview?” and then provide a discussion of key points they should have gleaned from the interview.</td>
</tr>
<tr>
<td><strong>Course of Action</strong></td>
<td>The <strong>Course of Action</strong> screen has a &quot;Superlist&quot; of options that the learner can recommend for the VP. The VP responds to each option.</td>
</tr>
<tr>
<td><strong>Multiple Choice Question</strong></td>
<td>The <strong>Multiple Choice Question</strong> screen can be either a multiple choice, multiple select, or t/f question that you ask the learner.</td>
</tr>
<tr>
<td><strong>Feedback</strong></td>
<td>The <strong>Feedback</strong> Screen can be linked to either an Interview screen or a Course of Action screen. It provides feedback to the learner based on values you assigned to each question or option.</td>
</tr>
</tbody>
</table>
GENERAL NAVIGATION
(or, A Quick Overview of How to Create a Scenario)

Click the File pulldown menu to save your scenario (save often!). Select “Create Course” to generate the web-ready scenario files.

Click the Screen pulldown menu to delete a screen, or to “Preview” a screen to see what it will look like in the completed scenario.

Each screen has fields into which you enter information. You can cut and paste text from Word into these fields.

Most fields have default text that you can change.

You can upload graphics for each screen.

To add a screen to the flowline: Click on the type of screen you want and drag it to the flowline. Note that the Title screen is always the first screen in any scenario. You can add any screen to the flowline, in any order. You may need to scroll down to create space to add more screens, but there is no limit.

To delete a screen: Click on the screen you want to delete. (A little pointer will appear in the bottom left corner of that screen to indicate that it is selected.) From the menu bar at the top of the screen, select Screen → Delete screen. (Hitting the “delete” key on your keyboard won’t work - we didn’t want to make it easy to delete a screen!)

To reorder the screens: Click on the screen you want to move. (A little pointer will appear in the bottom left corner of that screen to indicate that it is selected.) Click it again and drag it to the place you want to move it. Release the mouse button.
PROCESSING PHOTOS FOR THE ISB USING PHOTOSHOP

Correct processing is essential! If you don’t process your photos as follows, they won’t show up in your scenario.

Step 1. Size your graphic to 300 pixels wide by 340 pixels high.
Open your graphic in Photoshop. (If it’s really big, you might want to reduce it first using Image --> Image Size and changing the pixel dimensions. If you’re using photos from a digital camera, the files are probably going to really big - scale them down to approximately 600 pixels just so you’re not dealing with a really huge graphic.)

Then, select the rectangular marquee tool, set the Style to “fixed size” and set the width to 300 px and the height to 340 px as shown.

Click your mouse in the graphic. A selection box will show up (a running dotted line). Click your mouse to move the box around to center it over your graphic. Then select Image → Crop.

Step 2. Save the graphic as a jpg.
Go to File → Save As. Under “Format” click on the pulldown menu arrow to select JPG.

Step 3. Name the graphic.
Important: Make sure the letters are all lowercase. Also make sure that the “ICC Profile” and “Use Lower Case Extension” boxes are checked as shown. Then click the Save button.

Step 4. Save the graphic
After you click Save, the following dialogue box will appear. Make sure that the Baseline (“Standard”) Format Option is selected. Then click the OK button.
IMPORTING PHOTOS

To import photos on a screen:

Step 1. Click the “Choose” button.

Step 2. Browse to the folder into which you have saved your photos.

Step 3. Click once on a photo and then click the “Select” button.

Note: You can import all of your photos at once and then select whichever one you want for each screen.
USING VIDEO INSTEAD OF STILL PHOTOS

In this version of the ISB, it is possible to use Flash video clips instead of jpgs. The video must be saved as a .flv file in Flash version 8.

Andy - add info about any necessary compression settings for the video.

You can import a .flv file just like you would import a jpg.
THE TITLE SCREEN

The Title screen is a default screen that must appear as the first screen of your scenario.

You need to enter:

Module Title: The title of your scenario.

Author: Your name.

Author department: Your department or company.

Screen photo: Use the default photo or choose your own. (Note: you must size your own photo in Photoshop so it has the right dimensions.)

A title screen will end up looking something like this:
THE TEXT SCREEN

The Text screen has a place for text and a graphic (or just text). You can use this screen to introduce the scenario to the learner.

You need to enter:

Screen Description: This information won’t appear on the screen - it will appear on the “site map” if the learner clicks “Help” in a finished scenario. It should be a brief description of the screen. For example, “Introduce the scenario.”

Screen Title: Enter the title of the screen.

Instructions: You can use the default instructions or write your own.

Screen text: The text that will appear on the screen.

Screen photo: Choose a photo.

A text screen will end up looking something like this:

There is no limit to how much Intro text you can enter since the text box will scroll.
THE INTERVIEW SCREEN

The Interview screen is where you enter all of the questions in your superlist. The learner clicks on each question and they get the virtual person’s response in a text balloon.

An interview screen will end up looking something like this:
ADDING INTERVIEW QUESTIONS (OR ITEMS)

Click here to add a question (or statement or action). This opens the screen shown below where you enter the information.

Add more cues that the photo doesn’t convey, like “the person starts crying.”

Type a question here. For example, “What is your name?”

Type the virtual person’s response to the question here.

Enter a brief rational for why this is a good or bad question.

Assign a value of 1, 2, 3 or 4 to each question (see Question Value Key below).

See next screen for details.

Question Value Key:
4 = excellent question
3 = OK, but not the best
2 = not useful
1 = harmful or detrimental
ADVANCED INTERVIEW FEATURES: PREREQUISITES

You can specify prerequisite questions, statements, or actions (for example, if you want the learner to ask the virtual patient their name before asking a more personal question).

Click the “Specify Prerequisites” button. This screen will appear. Click on each question that the learner must ask before he or she can ask the current question.
ADVANCED INTERVIEW FEATURES: GUIDELINES

The guidelines provide a way for you to categorize each question or statement according to a model, framework, or principle. This feature is optional. The ISB can evaluate whether or not learners have successfully selected items from each category of the model.

To enter guidelines, click the “Question Guidelines” button on the Interview screen.

- You can have up to 6 guidelines.
- If you have specified guidelines, the feedback screen will display whether or not they asked questions from each guideline in a column labeled “Guidelines.”
- If you haven’t specified guidelines, the program will display “N/A” in this column.
- Note: guidelines do not cross interviews. If you have more than one interview, you must enter the guidelines separately for each one.
ADVANCED INTERVIEW FEATURES: LEVELS OF IRRITATION

This tool is set up for the virtual person to express frustration if the interview is taking too long. Frustration is expressed after the learner selects 1- or 2-value questions for the 5th, 10th, 15th, or 20th time. For example, if the learner asks the virtual patient 5 1- or 2-value questions, the virtual patient’s response will say “Isn’t this taking a long time?” and also give their response to the question.

You can change the frustration text on the Interview screen by clicking the “Interviewee Feedback” button. (If you delete the text entirely, it won’t show up in the finished scenario.)
EDITING INTERVIEW QUESTIONS (OR ITEMS)
You can change the question, answer, value, or any other aspect of each question. You can also reorder the questions.

To edit a question:

To reorder questions:
THE Q&A SCREEN

The Q&A Screen allows you to pose a question to the learner and they click the “Discussion” button for more information.

A Q&A screen can look something like this:
THE COURSE OF ACTION SCREEN

The Course of Action screen allows the learner to select action items that they would recommend for the person they’re interviewing.

You need to enter:

- What the option is
- The virtual person’s response to the option
- A rationale for the option (is it a good one or not?)
- The value of each option:
  4 = excellent
  3 = OK, but not the best
  2 = not useful
  1 = harmful or detrimental

A finished Course of Action screen will look something like this:

For the most effective simulations, we recommend that you write a large number of options. Just like the questions in an Interview, there should be a range of options - some appropriate, some inappropriate.
Editing Options
As with the Interview screen, you can edit or reorder the options. Click on the text of the option to open the edit screen.

To reorder the options, click on the number of the option and drag it where you want it to go. (Just clicking on the number moves the option to the end of the list.)
THE FEEDBACK SCREEN

You can provide feedback to the learner after an interview or course of action screen. You do not need to enter anything for feedback screens - the ISB automatically tracks the value of the questions and statements you entered and generates this screen.

After you have placed a Feedback Screen on the flow line, click the drop-down arrow:

Then, select the screen (either an Interview or Course of Action screen) that you want the Feedback screen to be “linked” to.

A feedback screen looks like this:

Key Questions Asked or Statements Made:
Lists all the 4-value questions and statements that the learner selected, the patient response, the relevant guideline (if applicable) and the rationale for the question.

Key Questions or Statements Missed:
Lists all the 4-value questions and statements that the learner missed, the patient response, the relevant guideline (if applicable) and the rationale for the question.

Ineffective Questions or Inappropriate Statements:
Lists all the 1- and 2-value questions and statements that the learner selected, the patient response, the relevant guideline (if applicable) and the rationale for the question.

Note: Value 3 items do not appear in the feedback.
THE MULTIPLE CHOICE QUESTION SCREEN

The **Multiple Choice Question** screen allows you to ask a multiple choice (one correct answer) or multiple select (more than one answer). You can also use this for True/False questions.

Enter answer option here. Use one line for each option.

If the answer is correct, click in the box. (There can be more than one correct answer.)

Type the feedback users get when they are correct here.

Type feedback for incorrect answers here.

Type the question here.
SAVING AND PUBLISHING YOUR SCENARIO

Saving Your Work

- Save your work as you go along! The program doesn't automatically save, so you need to be vigilant about saving your work.
- The first time you click the Save button, it will prompt you to specify the folder that you want to save the scenario in.

Publishing Your Scenario

- When you have finished entering information for each screen and are ready to publish your scenario, click File → Create Course.
- The program will ask if you want to save your work before continuing - make sure you have saved your work!
- The program will then prompt you to specify the folder that you want the scenario saved in.
- A pop-up dialogue box will confirm that your file was saved.
- For testing purposes, we recommend previewing your scenario frequently and exporting the course as you go along.
VIEWING A COMPLETED SCENARIO

To look at your completed scenario:

Note: You need to have the Flash player installed to run the scenario. Here is the URL to download the Flash player: http://www.macromedia.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash

In the folder where you saved your scenario, there should be four files:

1. Images (all of the JPGs you use in your scenario are copied into this folder)
2. yoursenario.html (it will be called whatever you named it). This is a web page that holds the Flash movie.
3. yoursenario.swf (this the Flash file that pulls information from your data file)
4. scenario.xml (this is the data file)

To view your scenario, double click on yoursenario.html (or open it manually in an internet browser).

To upload your scenario to the web:

Work with your network administrator to upload the 4 files to your server.
CONTACT INFORMATION

Louise Delagran
Education Specialist
delag002@umn.edu
612-625-2197